Yaris Cross Forum banner
1 - 2 of 2 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Has anyone else had problems starting their Yaris cross in the recent cold weather. Both my daughters’ cars have failed to start from cold and are still only 9months old. I’m wanting to know if this is an issue with the Yaris cross.
 

· Registered
Joined
·
1 Posts
Yes. We have one that is also about the same age. Failed to start out of the blue ten days ago. The AA started It and advised us to start it and let it run for an hour every 7 days. Used it the following week and went to run it this morning - just 4 days after it was last run - dead again. The AA started it again and have now advised that we get the 12v battery throughly tested by a main agent. It’s apparently a very small battery.
Has anyone else had problems starting their Yaris cross in the recent cold weather. Both my daughters’ cars have failed to start from cold and are still only 9months old. I’m wanting to know if this is an issue with the Yaris cross.
Has anyone else had problems starting their Yaris cross in the recent cold weather. Both my daughters’ cars have failed to start from cold and are still only 9months old. I’m wanting to know if this is an issue with the Yaris cross.
Has anyone else had problems starting their Yaris cross in the recent cold weather. Both my daughters’ cars have failed to start from cold and are still only 9months old. I’m wanting to know if this is an issue with the Yaris cross.
 
1 - 2 of 2 Posts
Top